Zarplotter 4-motor drawing machine

Home Forum Everything Else Zarplotter 4-motor drawing machine

Tagged: 

Viewing 15 posts - 101 through 115 (of 115 total)
  • Author
    Posts
  • #23214
    Avatarcpcoe
    Participant

    hmm, I have searched all the files in the makelangelo-firmware folder and could not find a reference to printconfig(). any clues as to where I might look further?

    #23216
    Avatarcpcoe
    Participant

    ok, silly me, I found printConfig in the makelangelo-firmware file, but this file already has eeprom.h included, what gives? I also don’t see loadVersion() within the prinConfig() function, is that strange?

    #23217
    DanDan
    Keymaster

    I would check for a missing } somewhere above it in the code.

    #23220
    Avatarcpcoe
    Participant

    Dan, thanks for all the help here!

    so far I’ve tackled a bunch of errors by correcting possible syntax issues, yet more keep popping up, hopefully I’m not just chasing my tail!

    is it normal to have this many errors?

    full circle and back again to printConfig. this is the one that stumps me currently:

    Makelangelo-firmware:148:16: error: expected constructor, destructor, or type conversion before ‘;’ token

    printConfig(); {

    #23222
    DanDan
    Keymaster

    It isn’t. It all compiled ok the last time I used it. I’ll poke the code today and see if it’s something I did. Give me ~an hour.

    #23224
    DanDan
    Keymaster

    Yeah, there’s definitely something sketchy with your copy. I have recompiled mine with BOARD_RAMPS and MACHINE_ZARPLOTTER to be sure it’s ok.
    Grab the latest from github from the dev branch: https://github.com/MarginallyClever/Makelangelo-firmware/tree/dev

    #23232
    Avatarcpcoe
    Participant

    if this compiles nicely for you then it stands to reason I must be doing something wrong. this may happen in the beginning, I follow the steps in the README file but there are other steps I end up having to take that aren’t listed there, such as actively importing all the .h files in the sketch and having to download the U8glib.h file online in order to import it to the sketch. this is all stuff I’m assuming is normal but maybe its actually where the confusion begins? please advise

    after starting over with the latest from GitHub and going through the extra steps above, I get stuck much earlier in the compiling than before:

    In file included from C:\Users\casey\AppData\Local\Temp\arduino_build_949207\sketch\configure.h:208:0,

    from C:\Users\casey\Downloads\Makelangelo-firmware-master\Makelangelo-firmware-master\Makelangelo-firmware\Makelangelo-firmware.ino:11:

    motor.h:34:17: error: ‘NUM_MOTORS’ was not declared in this scope

    SegmentAxis a[NUM_MOTORS+NUM_SERVOS];

    in motor.h there is no include for robot_zarplotter.h, so I figure it needs this for reference to the #define NUM_MOTORS contained within. I’ve added this include several places in motor.h with no luck, thoughts?

    #23233
    DanDan
    Keymaster

    Check that you have latest arduino.

    All the files from the project should be in a folder named Makelangelo-firmware. That’s the cop and h and ino files.

    Opening th ino file should create lots of tabs in the app.

    Set the tools>Board type to mega 2560
    In configure.h, set the board and the machine style.

    compile.

    #23239
    Avatarcpcoe
    Participant

    ok, that makes sense, but for me the INO file opens and there is only one tab.

    this must be very tiring for you, I apologize 🙂

    I believe I’m current with Arduino and the makelangelo versions, I’m very new to all of this so the answer is most likely a very simple step I’ve missed!

    #23240
    DanDan
    Keymaster

    If the folder does not match the ino name then arduino MOVES THE FILE to a sub-folder with the correct name. This has caused me no end of grief.

    #23264
    Avatarcpcoe
    Participant

    thx, that was dead on, I found the sub-folder and pulled the file back out. now when I open the INO file I get all the tabs:)

    however, when I attempted to compile I still had to feed in external version of u8glib.h and clib/u8g.h.

    compiling with these got me all the way to the “linking everything together stage but then I received:

    C:\Users\casey\AppData\Local\Temp\cc7Id92B.ltrans1.ltrans.o: In function `main’:

    <artificial>:(.text.startup+0x198): undefined reference to `u8g_Begin’

    I don’t know what “function ‘main'” is but I tracked down u8g_Begin and did not see any obvious syntax issues,

    I’m assuming (probably wrongly) that my problem is with these .h files and tied to the fact that I’m having to import them. where are they normally found?

    #23270
    DanDan
    Keymaster

    https://www.arduinolibraries.info/libraries/u8glib

    should be install-able through the arduino libraries feature. search for u8g.

    #23278
    Avatarcpcoe
    Participant

    wow, Dan, what a rollercoaster! but I am having fun 🙂

    it seems that I had imported the u8glib files, without using the Arduino library manager, so they were tabs in the sketch. I’ve since deleted these and done as you said and now everything compiles nicely! However, at the very end it mentions that the memory is low… normal?

    the next issue is the LCD screen is blank, I’ve double checked that configure.h identifies the correct LCD and tweaked the contrast pot any ideas?

    #23279
    DanDan
    Keymaster

    um… if you have a standard 4×20 lcd like we use then you shouldn’t need u8g. u8g is for the full graphics lcd. so probably switch which lcd is being used and it might work then. why didn’t i think of that earlier…

    #23281
    Avatarcpcoe
    Participant

    oh, yes, the full graphics LCD is what I have, sorry I wasn’t clear! I believe I have uncommented the correct LCD in configure.h:

    // only uncomment one of these options
    #define LCD_IS_128X64 // reprapdiscount Full Graphic Smart LCD Controller
    //#define LCD_IS_SMART // reprapdiscount Smart LCD Controller (including XXL model)

Viewing 15 posts - 101 through 115 (of 115 total)
  • You must be logged in to reply to this topic.