MEGA + RAMPS Cant Connect Software

Home Forum Makelangelo Polargraph Art Robot MEGA + RAMPS Cant Connect Software

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #29164
    AvatarTylor Koenigsfeld
    Participant

    Hi all,

    I would like to get this setup to draw stuff for a children’s hospital, I would appreciate any help!

    Im using an Arduino MEGA + RAMPS 1.4. It came off of a basic kit on amazon that includes a LCD + SD reader. I have uploaded the firmware and I can confirm it works by using the D11 serial code. I cant get the software to connect to the MEGA. The software crashes when clicking “connect” using Java 8-271. The software does not crash, but nothing happens when connecting using Java 8-161.

    In both cases, when connect is pressed, the mega seems to restart. The Marginally Clever logo reappears. Im really at a loss here after messing around with it and digging in the fourms for a couple nights now. Any tips or pointers would be really helpful.

    Below are my Java crash log + D11 output. Thanks for reading.

    Using the newest nightly jar file
    makelangelo.version=7.23.0

    Firmware is version 9.2

    HELLO WORLD! I AM POLARGRAPH #-1
    Firmware v10
    Built Jan  1 2021 21:38:28
    == http://www.marginallyclever.com/ ==
    As well as the following G-codes (http://en.wikipedia.org/wiki/G-code):
    G00,G01,G02,G03,G04,G28,G90,G91,G92,M18,M100,M101,M114
    Has LCD`
    
    Adjusting limits.
    Saving calibration.
    
    
    
    Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
    j  jssc.SerialNativeInterface.openPort(Ljava/lang/String;Z)J+0
    j  jssc.SerialPort.openPort()Z+65
    j  com.marginallyclever.communications.serial.SerialConnection.openConnection(Ljava/lang/String;)V+28
    j  com.marginallyclever.communications.serial.SerialTransportLayer.openConnection(Ljava/lang/String;)Lcom/marginallyclever/communications/NetworkConnection;+11
    j  com.marginallyclever.communications.serial.SerialTransportLayerPanel.openConnection()Lcom/marginallyclever/communications/NetworkConnection;+27
    j  com.marginallyclever.communications.ConnectionManager.requestNewConnection(Ljava/awt/Component;)Lcom/marginallyclever/communications/NetworkConnection;+125
    j  com.marginallyclever.makelangelo.Makelangelo.requestNewConnection()Lcom/marginallyclever/communications/NetworkConnection;+8
    j  com.marginallyclever.makelangeloRobot.MakelangeloRobotPanel.openConnection()V+4
    j  com.marginallyclever.makelangeloRobot.MakelangeloRobotPanel.actionPerformed(Ljava/awt/event/ActionEvent;)V+28
    j  javax.swing.AbstractButton.fireActionPerformed(Ljava/awt/event/ActionEvent;)V+83
    j  javax.swing.AbstractButton$Handler.actionPerformed(Ljava/awt/event/ActionEvent;)V+5
    j  javax.swing.DefaultButtonModel.fireActionPerformed(Ljava/awt/event/ActionEvent;)V+34
    j  javax.swing.DefaultButtonModel.setPressed(Z)V+117
    j  javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Ljava/awt/event/MouseEvent;)V+35
    j  java.awt.Component.processMouseEvent(Ljava/awt/event/MouseEvent;)V+64
    j  javax.swing.JComponent.processMouseEvent(Ljava/awt/event/MouseEvent;)V+23
    J 2183 C1 java.awt.Component.processEvent(Ljava/awt/AWTEvent;)V (220 bytes) @ 0x000001f03d18b884 [0x000001f03d18b360+0x524]
    J 2010 C1 java.awt.Container.processEvent(Ljava/awt/AWTEvent;)V (22 bytes) @ 0x000001f03d106a4c [0x000001f03d106720+0x32c]
    J 1946 C1 java.awt.Component.dispatchEventImpl(Ljava/awt/AWTEvent;)V (921 bytes) @ 0x000001f03d0ba6b4 [0x000001f03d0b5180+0x5534]
    J 1728 C1 java.awt.Container.dispatchEventImpl(Ljava/awt/AWTEvent;)V (129 bytes) @ 0x000001f03d02040c [0x000001f03d0202c0+0x14c]
    J 2195 C1 java.awt.LightweightDispatcher.retargetMouseEvent(Ljava/awt/Component;ILjava/awt/event/MouseEvent;)V (372 bytes) @ 0x000001f03d19aa1c [0x000001f03d198200+0x281c]
    J 2145 C1 java.awt.LightweightDispatcher.processMouseEvent(Ljava/awt/event/MouseEvent;)Z (286 bytes) @ 0x000001f03d1726fc [0x000001f03d170fc0+0x173c]
    J 1961 C1 java.awt.LightweightDispatcher.dispatchEvent(Ljava/awt/AWTEvent;)Z (73 bytes) @ 0x000001f03d0c37bc [0x000001f03d0c3380+0x43c]
    J 1728 C1 java.awt.Container.dispatchEventImpl(Ljava/awt/AWTEvent;)V (129 bytes) @ 0x000001f03d0203ac [0x000001f03d0202c0+0xec]
    J 1953 C1 java.awt.Window.dispatchEventImpl(Ljava/awt/AWTEvent;)V (23 bytes) @ 0x000001f03d0b1da4 [0x000001f03d0b17c0+0x5e4]
    J 1754 C1 java.awt.EventQueue.dispatchEventImpl(Ljava/awt/AWTEvent;Ljava/lang/Object;)V (149 bytes) @ 0x000001f03d0308fc [0x000001f03d02f080+0x187c]
    J 1752 C1 java.awt.EventQueue$3.run()Ljava/lang/Void; (60 bytes) @ 0x000001f03d02e45c [0x000001f03d02e240+0x21c]
    J 1751 C1 java.awt.EventQueue$3.run()Ljava/lang/Object; (5 bytes) @ 0x000001f03d02decc [0x000001f03d02de40+0x8c]
    v  ~StubRoutines::call_stub
    J 1012  java.security.AccessController.doPrivileged(Ljava/security/PrivilegedAction;Ljava/security/AccessControlContext;)Ljava/lang/Object; (0 bytes) @ 0x000001f03ce220a6 [0x000001f03ce22040+0x66]
    J 1791 C1 java.awt.EventQueue$4.run()Ljava/lang/Object; (5 bytes) @ 0x000001f03d04aa74 [0x000001f03d04a640+0x434]
    v  ~StubRoutines::call_stub
    J 1012  java.security.AccessController.doPrivileged(Ljava/security/PrivilegedAction;Ljava/security/AccessControlContext;)Ljava/lang/Object; (0 bytes) @ 0x000001f03ce220a6 [0x000001f03ce22040+0x66]
    J 1699 C1 java.awt.EventQueue.dispatchEvent(Ljava/awt/AWTEvent;)V (80 bytes) @ 0x000001f03d00b9fc [0x000001f03d00ab40+0xebc]
    J 1755 C1 java.awt.EventDispatchThread.pumpOneEventForFilters(I)V (190 bytes) @ 0x000001f03d032d9c [0x000001f03d031c40+0x115c]
    j  java.awt.EventDispatchThread.pumpEventsForFilter(ILjava/awt/Conditional;Ljava/awt/EventFilter;)V+35
    j  java.awt.EventDispatchThread.pumpEventsForHierarchy(ILjava/awt/Conditional;Ljava/awt/Component;)V+11
    j  java.awt.EventDispatchThread.pumpEvents(ILjava/awt/Conditional;)V+4
    j  java.awt.EventDispatchThread.pumpEvents(Ljava/awt/Conditional;)V+3
    j  java.awt.EventDispatchThread.run()V+9
    v  ~StubRoutines::call_stub
    
    • This topic was modified 3 weeks, 1 day ago by DanDan.
    • This topic was modified 3 weeks, 1 day ago by DanDan.
    • This topic was modified 3 weeks ago by DanDan.
    #29170
    DanDan
    Keymaster

    It looks like this is a windows security issue. Windows Firewall(?) likes to block unrecognized apps from opening COM ports.

    Windows serial connection problems

    #29173
    AvatarTylor Koenigsfeld
    Participant

    So sorry, forgot to mention that I have read that post and done everything in there.

    Java.exe, the SE binary and OpenJDK all have access through the firewall as per your guide. I have tested disabling the firewall and the issue still persists. Do you prefer to use linux for this? Any other ideas?

    If I can get this figured out I would gladly make a donation to the children’s hospital on your behalf, thanks for the reply.

    #29182
    AvatarTylor Koenigsfeld
    Participant

    So it seems to connect fine on my desktop, my laptop however does not work. I ended up resetting my laptop to factory settings and installed the newest x64 Java. It still crashes when connecting with the same error. It is allowed through windows defender and still crashes even when windows defender is disabled. Any ideas?

    #29183
    AvatarTylor Koenigsfeld
    Participant

    For anyone who has this issue, Java 8-261 does not seem to work for makelangelo. Java 8-161 seems to work correctly when connecting

    #29200
    Avatarjoerandomnumber
    Participant

    Thanks for the update. I’m having the same jssc.SerialNativeInterface.openPort failure, and I have 8-271. Unfortunately, Oracle is “experiencing technical difficulty” (which apparently is their MO) so I can’t download 8-161.

    #29208
    Avatarjoerandomnumber
    Participant

    I tried Oracle download again today and got it to work. I found that the website gave the error message if I clicked the download link and then log in when the download requested it. Instead, I had to log in to Oracle separately from the download process, and then the download would work after that. Downloaded 8-161 and installed it, then uninstalled 8-271 and rebooted. The Makelangelo app will now connect without crashing.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.