Makelangelo on Arduino Uno

Home Forum Makelangelo Polargraph Art Robot Makelangelo on Arduino Uno

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #12860
    Avatarartclonic artclonic
    Participant

    Hi, how to run the Makelangelo on Arduino UNO ? I downloaded the firmware MarginallyClever-Makelangelo-firmware-c86acee

    #12865
    Avatarartclonic artclonic
    Participant

    need firmware “Makelangelo 2.5.2 ? Where to download it?

    #12894
    DanDan
    Keymaster

    Firmware can be downloaded from this site, here: https://www.marginallyclever.com/product/makelangelo-firmware/

    The firmware_ams folder contains the UNO version of the Makelangelo code.

    #12909
    Avatarartclonic artclonic
    Participant

    What limiting uno+shield compared to the Mega+ramps? What does this mean?

    #12910
    Avatarartclonic artclonic
    Participant

    what are the consequences and limitations?

    #12976
    AvatarAnonymous
    Inactive

    @Artclonic, did you get any feedback on your questions?

    @Dan,
    I know have the software running and firmware installed in an UNO with a cheap zyltech driver. The problem I am having is when I try to draw the steppers just hum. I thought it might be an issue with jumper settings (I had them all installed) but it acted the same after I powered it all down and removed all the jumpers. Any help would be appreciated.
    Curt

    #12999
    DanDan
    Keymaster

    RAMPS and RUMBA can move many times faster and boards can be recycled later to make 3D printer. L293D shield isn’t good for much else.

    @curt locey I’m not familiar with zyltech driver. link to specific item? photo of your setup?

    #20181
    AvatarAnonymous
    Inactive

    I tried to make Makelangelo w. 5.2.. Using arduino uno.. And i installed this firmware to arduino.. And then i installed Makelangelo-software…. When i try to connect tge arduino via Makelangelo-software an error message pops up sayung

    “the firmware (code in the brain of your robot) is not the version I expect. I found v7..”

    How should i overcome this error…

    #20182
    AvatarAnonymous
    Inactive

    Makelangelo 2.5.2

    #20222
    DanDan
    Keymaster

    Makelangelo 2.5.2 is no longer supported by the software.
    I don’t have the resources to support every version.
    If you modify the code to support 2.5.2 and send in a pull request then I welcome it.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.