Can't change settings on software

Home Forum Makelangelo Polargraph Art Robot Can't change settings on software

Viewing 25 posts - 1 through 25 (of 40 total)
  • Author
    Posts
  • #13603
    AvatarAnonymous
    Inactive

    I can’t change any settings on Makealengelo Software. (Pen diameter, speed, etc.)

    Is it about Java version or what ??

    Please help me !

    #13610
    DanDan
    Keymaster

    Please tell me more. What os, what machine, what version of the software, and what steps do I follow to reproduce your results?

    #14018
    AvatarAnonymous
    Inactive

    Hello,

    first of all, thank you for what you do!

    I am writing because I have the same problem: I will try to provide a detailed explanation ๐Ÿ˜‰

    I am using versions 7.9.0/7.10.0/7.11.0 of Makelangelo software and I am on Windows 7 64bit + Java V8 (update 144).

    The software doesn’t keep the modified parameters: if I go Settings -> Pen -> I edit the diameter -> Ok => when I open the Settings again, the value that I’ve edited is lost

    At the moment, I have found a workaround: once I open the Settings -> I change the Paper Size from the menu (e.g. A2->A3 – but also if I just open the list and I re-select the current value, A2->A2 -) -> then (for example) I go to the Pen tab -> I edit the pen’s diameter -> Ok => in this case if I open the Settings again, the value is retained

    The same happens with other parameters: if I select “Is landscape?” from the Paper tab and I click Ok, next time I’ll open Settings the selection will be lost; if I open the Paper Size menu and I select a value from the list (even the one already selected) and then I select “Is landscape?” and I hit Ok, then the value is kept.

    It seems to me, that only if the event of selection from the Paper Size menu occurs, the values in the other fields are stored.

    I have also made a short video of the behavior, you should find it here: https://ufile.io/lh4oe

    In case you are not able to see it, please let me know (I could send it via email, it is just ~1.5MB).

    I hope this will help: I can do some specific tests if you require that.

    #14195
    AvatarAnonymous
    Inactive

    up

    #14196
    DanDan
    Keymaster

    Is your machine #-1?

    #14355
    AvatarAnonymous
    Inactive

    Yes, in my case I can confirm that, the machine is listed as #-1 and I don’t have other options in the list.

    #14359
    DanDan
    Keymaster

    Huh. Ok. Machine -1 means that the device has never phoned home to get a unique id. they try to and – in return – i get to track how many machines have been built. it’s probably overwriting settings for machine -1 every time the app starts.

    easiest fix is put the computer online, connect to the robot, it will be given a number, and then you’re good after that.

    #14364
    AvatarAnonymous
    Inactive

    I am running the firmware on a custom setup (e.g. custom hardware with a RAMPS board), I don’t know if this can make a difference. The firmware is mostly untouched, with the exception of some parameters related to the IO ports for the drives and the parameters related to motors’ steps and pulleys’ sizes.

    The computer on which the app is running is connected to internet. Anyway, if I run the app launching “start windows.bat” nothing happens: I am only able to run it directly from the .jar file.

    #14365
    DanDan
    Keymaster

    None of which affects the -1. the board is trying to save the machine number into EEPROM, the tiny hard drive like space in it’s head. If that write is failing then the number stays at -1. also if the phone call to get the UID fails, the number would never be updated.

    Since you have a custom setup it’s really hard to tell where the point of failure occurs.

    #14369
    AvatarAnonymous
    Inactive

    Uhm, ok, I am familiar with microcontroller ๐Ÿ˜‰ so, as a workaround, I can either store a robot_id in the eeprom calling the saveid function (if the write eeprom procedure is working on my board..) or I could force a value for robot_id inside the “load from eeprom” function.. Right?

    #14370
    DanDan
    Keymaster

    yes. afaik no one’s ever done it that way before…

    #14638
    AvatarAnonymous
    Inactive

    Hi Dan ๐Ÿ™‚
    I have the same problem: the machine is listed as #-1 and I donโ€™t have other options in the list.
    I canโ€™t change the pen parameters and I donโ€™t understand what I can do to correct that.

    #14698
    DanDan
    Keymaster

    if makelangelo software is on a PC that is on the internet when you connect to the robot… the app will see -1, phone home once, get a new global UID for the robot, and install that new UID. after that your machine will be something like #16905 and everything will be fine.

    @prenic, you can call “UID [a number]” in the arduino serial window to assign a new UID, no firmware hack required. replace [a number] with any number larger than zero.

    #14712
    AvatarAnonymous
    Inactive

    I am online. Whatever I do, I get the -1.
    I have turned off the virus protection program (trend micro). The change was: The makelangelo software 7.15.0 took three seconds instead of 70 seconds to start.
    The # -1 is always there.
    Does it make sense makelangelo software 7.15.0 or Aruino to delete and reinstall?
    Is there perhaps overlap with other programs? Firefox, Java, CNCC.COM, Inscape or DraftSight2017?
    What do you suggest?

    Thanks, Joram ๐Ÿ™‚

    #14720
    DanDan
    Keymaster

    The software does not overlap with any of them. Is the app blocked from internet access?
    If so, at the bottom of the screen on the left are two small arrows. click to expand the advanced controls.
    In the text field that appears at the bottom, type “UID 1” and hit “send”. This must be done while the robot is connected.

    After that it should always report as machine #1.

    #14724
    AvatarAnonymous
    Inactive

    Good, it worked. Now I can choose #1 or #-1. Thank you Dan ๐Ÿ™‚

    But I still can not change the pen size. It always jumps back to 0.8.

    And the worst: I can not finish a print when it is running on the PC.
    With the SD card no problem. With the PC the 3.2 stops after some time in the middle of the work.
    It runs slower and slower until it stops.

    #14739
    AvatarAnonymous
    Inactive

    a small file:

    http://fs5.directupload.net/images/171128/b9izfw2c.jpg

    89% and over. Stop.

    #14740
    DanDan
    Keymaster

    what does “83% and over. stop.” mean?

    #14742
    AvatarAnonymous
    Inactive

    Excuse me. My English is not good.:-(
    The program may run well for 20 minutes and then it slows down quickly until it stops.
    In this case, after 89% of the plot.

    #14743
    DanDan
    Keymaster

    and no error message in log file?

    #14744
    AvatarAnonymous
    Inactive

    I will check it again, but have not seen any.
    It’s more like memory overflow… The machine is waiting.

    #14745
    AvatarAnonymous
    Inactive

    Can it be that the problem has to do with how many windows of firefox I open ??? I wanted to watch a clip while testing – the machine has stopped. When I closed 3 Firefox windows, the machine has started again to work – for the first time…
    Now it works again, is not finished yet.

    #14746
    DanDan
    Keymaster

    sounds like you’re running out of memory.

    #14747
    AvatarAnonymous
    Inactive

    ??? 8GB RAM…

    88% of the work.

    That’s how the machine stopped. no error message:

    http://fs5.directupload.net/images/171128/rncz2v4h.jpg

    #14748
    DanDan
    Keymaster

    Wow, that’s a lot of ram. ….why….?

Viewing 25 posts - 1 through 25 (of 40 total)
  • You must be logged in to reply to this topic.