Arduino mega and ramps without led disolay

Home Forum Makelangelo Polargraph Art Robot Arduino mega and ramps without led disolay

Viewing 25 posts - 1 through 25 (of 46 total)
  • Author
    Posts
  • #20349
    AvatarAnonymous
    Inactive

    Can i run makelangelo without led display… If yes how will i change the source code to run the program and draw.??

    When i tried to draw an image an error message came

    N5 m117 change to black click to continue*47
    N6 m300 s60 p250*20
    N7 m226*34..

    And nothing happens… And i can draw vectors only… When i try to draw jpeg this error message comes.. And also the machine cant find home position… My machine size is 930 mm width and 563 mm height… … When i try to draw on a4 paper the image exceeds the paper.. Hope someone will help soon..

    #20362
    DanDan
    Keymaster

    Those three commands say

    – display message “change to black click to continue”
    – make beep sound
    – wait for user to click button

    If you have no LCD screen then you will not be able to proceed unless you upload firmware with HAS_LCD disabled.

    > When i try to draw jpeg this error message comes..

    What error message, specifically? Ugh.

    > And also the machine cant find home position…

    Why not? What happens? It sounds like you’re running a DIY Makelangelo 3 which cannot find home position automatically.

    > When i try to draw on a4 paper the image exceeds the paper..

    Did you go to settings > paper and choose A4?

    #20364
    AvatarAnonymous
    Inactive

    Hey.. Dan i figured out solutions for some of the problems my self bt….. I have some problems regarding the size… The image printed on the paper seemed to be squeezed from the top…… I couldnt correct this mistake..

    And also the size of the print is larger than that of the paper….
    How can i correct these dan?,

    #20365
    AvatarAnonymous
    Inactive

    I meant the machine draws outside the paper..

    #20370
    DanDan
    Keymaster

    Please post a screenshot of your app and a photo of your machine and the results drawn. Position the pen holder at the home position in the photo.

    #20377
    AvatarAnonymous
    Inactive

    Ok dan…
    Here are the links to my google drive

    https://drive.google.com/file/d/1-To6slQYx_d-BoePfyn8A78oHCzsmrrZ/view?usp=drivesdk

    https://drive.google.com/file/d/1otLFxEru2q8jpfLtnbwYDx2U-AM5OWOR/view?usp=drivesdk

    https://drive.google.com/file/d/18dYk53xh_gEZogR5U211tLXeJp5GUKuG/view?usp=drivesdk

    The width of the drawing is ok… But the height seems reduced.
    I dont know how to fix it
    .. Machine size is… Height = 569mm

    Width = 930 mm

    #20378
    AvatarAnonymous
    Inactive

    I selected A4 size… But when i drew first it drew outside the paper so I inserted a paper of bigger size so that i would get the complete image.. And after drawing i could tell from the image that it looked like it was squeezed….

    Is it because i measured the height of the machine wrong??

    #20379
    DanDan
    Keymaster

    Check your microstepping (should be 1/16th) and check your pulleys (20 teeth each).

    #20380
    AvatarAnonymous
    Inactive

    Yeaa i did that… And when i tried to draw a 10 mm square the dimensions were 15 mm in vertical side and 20 mm in horizontal side… So i figured that the machine draws a 5 mm excess on vertical side and 10 mm extra in horizontal moment… And what i am going to do is…. Ill try adjusting the size of the board… Ie incriment and decrement these values from size of the board πŸ˜‚πŸ˜‚.. I hope it works… And if there is any other soluthon please tell me and ill notify you if it works

    #20381
    DanDan
    Keymaster

    I suspect your pen holder design is a problem. measure the width from the center of each motor shaft and subtract the distance between the pins on the pen holder that attach to the belts. In my design the arms swivel around the pen tip. In your design they swivel around two different points and that has to be compensated.

    #20382
    AvatarAnonymous
    Inactive

    https://drive.google.com/file/d/19stH5xpUBgGjLNdqvn27BexmHczgDv0t/view?usp=drivesdk

    Dan the image above shiws the micro steps its 16.0 should i change it to 1/16

    #20383
    AvatarAnonymous
    Inactive

    I didnt understand what u said dan.. About the belt size?? Does belt size matter?

    #20384
    AvatarAnonymous
    Inactive

    Dan for drawing 10 mm vertically the machine draws 15mm

    And for drawing 10 mm horizontal the machine draws 20 mm…..

    Have you heard abt this type of error… I cant fix it by changing the mavhine size.

    Is there any other way to fix this??

    Considering the source codes side…
    Anything i can do to make macjine draw a 5mm less on the vertical side and 10mm less on the horizontal side

    #20385
    DanDan
    Keymaster

    I didn’t say belt size. the belts attach to your DIY pen holder about 8cm apart, on the brass colored pins. subtract the distance between the pins and you might get a more accurate picture.

    Also that distance between the pins will cause the pen holder to tilt sideways sometimes, which will also affect the quality of your drawing.

    #20389
    AvatarAnonymous
    Inactive

    Ahh thanks dan and ill notify if it works

    #20390
    AvatarAnonymous
    Inactive

    Dan i think it worked… I have srarted drawing… And ill post when it is over

    #20392
    AvatarAnonymous
    Inactive

    Dan please look into these files… The images are being drawn like this while drawing in cross hatch…

    https://drive.google.com/file/d/12-EehQqQGGWG-h0nfHDgB7sX96c4ZOvI/view?usp=drivesdk

    https://drive.google.com/file/d/1W0v9HeyXpp97UAbKQTEzVgapi-XWIrn3/view?usp=drivesdk

    I dont understand what the problem is…

    While drawing a 10*10*mm square the machine draws 20*20 mm… I dont kniw how to resolve this… The machine does draw svg perfectly.. Bt when it comes to jpeg its like this it draws like that as posted above

    #20393
    AvatarAnonymous
    Inactive

    The lines get offsetted i dont know what to do

    #20397
    DanDan
    Keymaster

    I’ve run out of ideas. I would need more information to see the problem.

    #20401
    AvatarAnonymous
    Inactive

    More informations like???

    #20406
    AvatarAnonymous
    Inactive

    Hey dan

    #20454
    AvatarAnonymous
    Inactive

    Hey dan the error still prevails can u help
    https://drive.google.com/file/d/10wo3Of91lm0QN1tl1RZ0gTGD9vSNFs4E/view?usp=drivesdk

    Please look into these file

    #20455
    DanDan
    Keymaster

    I need a more thorough description of your system because I don’t see what is going wrong.

    #20456
    AvatarAnonymous
    Inactive

    Thorough description like? Please help me out man

    #20457
    DanDan
    Keymaster

    I’ve tried to help you out. I didn’t build your machine so it could be a great many things.
    Try a video that shows the entire machine and then shows the system while it is making the problem.

Viewing 25 posts - 1 through 25 (of 46 total)
  • You must be logged in to reply to this topic.