Windows 8 Install Next Steps

Shop Forum Makelangelo Polargraph Art Robot Windows 8 Install Next Steps

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #6144

    I’m eager to get my Makelangelo running.
    Tried installing latest GitHub software (today’s version) on windows 8.1 machine.
    It’s obvious I’m missing a step.
    Installed Arduino. Installed Makelangelo. Copied over libraries AFMotor Drawbot
    Arduino shows Uno board on port 5 (correct).

    “Blink” LED code uploads and works fine.

    Trying to upload Motor Party from Arduino Message:
    Arduino: 1.6.5 (Windows 8.1), Board: “Arduino/Genuino Uno”

    MotorParty.pde:5:21: fatal error: AFMotor.h: No such file or directory
    compilation terminated.
    Error compiling.

    This report would have more information with
    “Show verbose output during compilation”
    enabled in File > Preferences.

    When launching the Makelangelo software, there is a quick flash with runtime 1.8 showing. A long string of text flashes, then widow closes. Not sure how to stop window from closing to read message.
    Ideas welcome and appreciated to get Makelangelo interface going.


    try making a file called start.bat. inside the file put

    java -jar makelangelo.jar

    then double click the start.bat file. it should run and keep the window open.

    What is MotorParty? This is the second time I hear about it, both in support questions about Makelangelo.


    Motor Party Info-
    One of the Arduino examples in the Ada Fruit collection. It can be used to test the connections of the Motor Shield.

    One solved issue?- had extracted the Makelangelo files into the Program Files (x86) Due to my education establishment settings, the program folder did not permit the making of the log file. Moved to documents folder.

    I modified the start.bat file, and was able to get the message:
    Libpng warning:iCCP: known incorrect sRGB profile
    Oct 26, 2015 9:00 PM java.util.prefs.WindowsPrefereces
    WARNING: Could not open/create prefs root node SoftwareJavaSoftPrefs at root ______ Windows RegCreateKeyEx(…) returned error code 5
    Exception in thread “AWT-EventQuere-0” java.lang.UnsatisfiedLinkError: _____ gluegen-rt.dll Can’t load AMD 64-bit .dll on a IA 32-bit platform.
    Then a lot of at java.awt… (Unknown Source) messages.

    Another issue I may have stumbled onto is not knowing how to install the firmware. I switched out the old folders for the new ones from Git Hub. Didn’t seem to make a difference. Hope the previous messages can help.


    What version of Makelangelo are you running, please? You shouldn’t get gluegen errors unless we did something wonky on our end.

    The warnings before the gluegen problem are known and non-fatal. They have to do with the security restrictions on your computer preventing the app from doing things like saving your preferences.


    The Read me says: Makelangelo v7 (The read me in the same folder as the start windows command)
    I assume it is version 7.1.1 as it came from GitHub


    I think the latest version was not packaged correctly. I will work on getting an update out today.


    Hello from France.

    I have exactly the same problem on my son’s computer under windows 8, and i am very interested in the solution…
    Best regards.


Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.