Windows 7 Install Next Steps?

Shop Forum Makelangelo Polargraph Art Robot Windows 7 Install Next Steps?

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #6142

    My goal is to run the Makelangelo off a Windows 7 Enterprise machine for my school. (finally upgrading from XP) Several machines are available for me to troubleshoot with.

    I think the latest version of the Makelangelo software is being used. (Oct 21 download- also downloaded firmware pieces, but these seem to be the same as the ones inside of the program) It runs enough to show the picture of the Makelangelo, and ask me my language preference. Then there is a series of quick command prompt words (beginning with Java runtime 1.7), then everything closes up. What should I try next?

    Downloaded Makelangelo software. Saw picture of Makelangelo, asked language, stopped. Driver has USB device as “unkown” and not functioning.
    Downloaded Arduino 1.6.5. Ran install, including USB drivers. Restarted. Driver now knows USB and has labeled board as UNO (which is correct) on COM port 5. Arduino has COM 5, and UNO (genuine) board selected. (Didn’t try anything else here.)
    Copied AF Motor library. Ran Arduino to confirm it is visible on menus.
    Start 32, and Makelangelo files have same result- opens command prompt, asks for language, flash of code and stops.

    Birdwalk- for what it’s worth, the Makelangelo version available last week 7.1.1 would open, and I could pick a COM port, but it didn’t connect to offer the “Hello World” message, nor move any motors. It would compile gcode for pictures. It still thinks it is up to date today. The most obvious difference in start up is that the picture of the Makelangelo doesn’t show.
    The new interface looks FANTASTIC, and I can’t wait to try it on my machine (#103).


    We have windows 7 here on one machine.
    Is the last official release. Does it run on windows 7 for you?
    Can you run it from the command line

    c:pathtomakelangeloappjava -jar Makelangelo.jar

    You may find this helpful, too:


    New message after reinstalling from the link:
    (Java runtime is 1.7 Same as before)
    java.lang.NullPointerException (This message will only appeared the first time)

    It took me a while to remind myself of some ancient command prompt navigation. At the end the result of using the command prompt is the same as double clicking on the jar file. The picture shows briefly, choose a language, Interface shows up, Pick a Com Port, No result. The log shows the port opening, but it doesn’t connect or show “Hello World” and just hangs here.

    This leaves me confused about a next step and doubting about the way I installed it. I extracted the files to a folder in my documents. Might it be better to put it somewhere else? Do Arduino files and Makelangelo files need to be in the same folder?


    Aruduino Test- Blink worked well Motor Party would not compile.
    Perhaps I have some of the pieces mixed up?

    Arduino: 1.6.5 (Windows 7), Board: “Arduino/Genuino Uno”

    MotorParty.pde:5:21: fatal error: AFMotor.h: No such file or directory
    compilation terminated.
    Error compiling.

    This report would have more information with
    “Show verbose output during compilation”
    enabled in File > Preferences.


    What is MotorParty? You should install


    I followed the download link, and have a folder of firmware.

    It wasn’t clear to me how to install it. What I tried was to replace the firmware_ams and firmware_rumba folders.

    The result was the same as before. The port opens but that’s the last message (No “Hello World” on log tab)
    It is interesting that there is no “picture” of the Makelangelo before choosing a language.
    Did I guess right? What next?


    Arduino software install instructions are here:

    Does that help?

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.