Switching Languages?

Home Forum Makelangelo Polargraph Art Robot Switching Languages?

This topic contains 4 replies, has 0 voices, and was last updated by Avatar EdmondsLibrarian 4 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #6145
    Avatar
    EdmondsLibrarian
    Participant

    My Makelangelo has the awesome capability of running in various languages. (version 7.1.0)
    Unfortunately, I selected a language I’m not familiar with. (Greek looks very cool.)
    Short of doing a reinstall, is there a file or line of code that can be removed to get the chance to pick again?

    #7201
    Avatar
    Anonymous

    On a windows computer the preferences are stored in the registry keys.

    First, stop the app.

    I believe you can search registry for “Drawbot” and then a sub-set called “Language” and finally a key called “language” who’s value is set to the current language. Delete the key/value pair, then restart the app. It will not find the key and offer the popup again.

    …I don’t actually know where the preferences are stored in OSX or linux.

    #7202
    Avatar
    Anonymous

    That search would be “draw/bot” in regedit

    Also do you think that there may be a reg entry affecting the paper & machine settings not working.

    I did not know that the program embedded itself into windows I thought it was riding on top of java. Now that opens a whole new can of worms.

    #7203
    Avatar
    Anonymous

    I used a “preferences” class available as part of java. Apparently in windows the native implementation uses registers. I didn’t know that until long after it was in use. Trying to replace it with something less ugly has created a lot of code in the app.

    http://docs.oracle.com/javase/7/docs/api/java/util/prefs/Preferences.html

    #7204
    Avatar
    Anonymous

    Hope you can work out the problems with 7 I like the new interface.

    Keep it up. Thanks

    #7205
    Avatar
    Anonymous

    @shadyoaks thanks 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.