[solved] How do you install firmware for GcodeCNCDemo?

Home Forum Everything Else [solved] How do you install firmware for GcodeCNCDemo?

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #6101
    AvatarAnonymous
    Inactive

    Mac OS 10.9.3 Arduino 1.6.3. Adafruit Motorshield V1.

    Exactly which files go in which folders and where should they be?

    Where are the documentation pages?

    Where are the instructions?

    I have completely removed Arduino, along with the dozen libraries I have previously used. On a fresh instal of Arduino I cannot compile it, because either afmotor or afmotordrawbot always ends up in the wrong place.

    I’ve tested my hardware with AFmotor multistepper and it performs flawlessly. I have been going round and round from GitHub to these forums to the blog to learn constantly following links to no avail.

    Can someone please explain how to use these “random” files that seem to be different here… https://www.marginallyclever.com/other/Makelangelo.dmg and here… https://github.com/MarginallyClever/Makelangelo/

    I’m at my wits end and have been at this for about 18 hours solidly.

    Thanking you all kindly.

    #7017
    AvatarAnonymous
    Inactive

    Problem solved!

    The folders Adafruit_MotorShield and AFMotorDrawbot need placing in the Library folder along with their contents and GcodeCNCDemo2AxisV2.ino should be opened then saved into your sketch folder.

    Restart the Arduino IDE after installing the 2 library folders.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.