[solved] Help loading software

Home Forum Makelangelo Polargraph Art Robot [solved] Help loading software

  • This topic is empty.
Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #5886
    AvatarAnonymous
    Inactive

    Hi… could someone please elaborate on the actual steps to install the software downloaded from github. I’m a relatively newbie at this… which file (or files) do I run to install the Drawbot software? I have Arduino up and running.

    Thanks in advance.
    Tom

    #6259
    AvatarAnonymous
    Inactive

    Please make sure you’re using the experimental branch of the software.

    If you copied the arduino firmware from github onto the arduino then the next step is to go to the /java folder and run DrawbotGUI.jar.

    At present there’s a few hoops to jump through to make it work, depending on what platform you use. I’m working on fixing that. What OS are you using?

    #6260
    AvatarAnonymous
    Inactive

    I’m running Windows Vista…

    Tom

    #6261
    AvatarAnonymous
    Inactive

    I’m actually writing some code right now that (I hope) will make it easier. I’ll let you know as soon as I have something that I think will work.

    #6262
    AvatarAnonymous
    Inactive

    Ok, I’ve checked in a newer version of the software. These instructions are valid as of version 0.8.4b.

    go to https://github.com/i-make-robots/drawbot/
    click on “ZIP” and extract the contents to a folder on your computer called DRAWBOT.

    – Install Arduino. (arduino.cc)
    – copy DRAWBOT/arduino/libraries/AFMotorDrawbot to your arduino/libraries/AFMotorDrawbot
    – double click on DRAWBOT/arduino/arduino.ino to open the firmware in arduino.
    -connect your drawbot to your computer. check in arduino > tools that the port and board type (UNO) are correct.
    – hit “upload”, the second button from the left that looks like an arrow pointing to the right. it should upload without an issue if all the previous steps are ok.
    – click on the button on the far right (serial monitor). a new window will pop up.
    – change the baud in the bottom right to 57600. a message should appear saying “HELLO WORLD, I AM DRAWBOT…” and a bunch of other stuff.
    – type “G00 Y10;” without the quotes. Both motors should move. (G-zero-zero means “move”. Y10 means “move up”. the semi colon is like the end of a sentence – without it the robot will keep waiting for instructions. if you forget it you can type “;” on the next line and everything will be fine.)

    Now we know the motors are connected, the firmware is running, and the robot is accepting commands. you can now close the arduino software.

    – DRAWBOT/Windows/start.bat can be double-clicked and should start the software for you.
    – if you do not immediately get a configuration screen, check that settings > port is set to the same value as you had in arduino.

    Settings > Configure Limits should appear when the port is correct and the robot is connected with firmware installed. It looks like this:

    This is where you tell the robot how big it is and where the paper is located. Without this the robot can’t do the math and refuses to do anything. You must put a paper size if you want to automatically convert pictures.

    L and R represent the two motors. 0,0 is where the pen starts drawing. My paper is 50cm wide, 61cm tall, and I want to start drawing in the middle of the picture. The hole on the motor mounts where the strings come out is 113cm apart. This is set up this way for those who want to change the starting point. note to self: make a simple config and an advanced config?

    Next is Settings > Configure bobbins. You may find that your bobbins aren’t exactly 0.8cm in diameter, so this is a chance to adjust them. 3D printed bobbins are pretty unreliable in this department, so measure them with some calipers.


    Settings > Jog Motors will help you wind the strings correctly. tie a loop in the end of your string, pass it through the hole in the side of the motor mount, then hook it on the set screw on the bobin. hit “in” until you feel you have enough string wound on the bobbin. If you’ve already got string wound you can test which way it turns and (if necessary) tick the “invert” checkbox to flip the direction without rewinding the bobbin.

    Now we’re reasonably sure the bobbins are wound right, the configuration is ok, and we’re ready to try moving around the board. Gently turn the bobbins until the pen is at the starting spot and then click Settings > Drive Manually.


    There’s a lot going on here. None of this is essential. All of it is useful to some degree.
    – GO TL/TR/BL/BR will drive the pen to each of the corners of your paper.
    – X[N] and Y[N] will move the pen N mm in that direction. X10 will move 10mm (1cm) to the right.
    – GO HOME will return to the starting position.
    – THIS IS HOME will order the machine to believe the pen is back at the start.
    – FIND HOME will only work if you have limit switches installed. If you don’t, make sure you disconnect your robot before it breaks the strings!
    – Z[N] will raise and lower the pen if you have that feature installed.

    This is a great way to driver your pen around etch-a-sketch style and to check that your settings are correct. For example, if you say Y10 and it goes X10 instead, it’s very likely one of your motors is inverted. If you say X10 and it moves X-10 then your left and right motors are swapped.

    Once you are confident that your configuration is right and that your motors are moving as they should, it’s time to send your pen to home (0,0) and start drawing.

    I hope this helps. Please send me any questions you have.

    #6258
    AvatarAnonymous
    Inactive

    Thank you for this new procedure…. I’ll try it this weekend.
    I appreciate your work to make this clearer!

    Tom

    #6263
    AvatarAnonymous
    Inactive

    https://github.com/i-make-robots/drawbot/ is not available anymore!?

    #6264
    AvatarAnonymous
    Inactive

    I’ve been trying to clean things up. It’s now at http://github.com/MarginallyClever/Makelangelo/
    Please tell me if you see the old link anywhere and I’ll do my best to fix it.

    Thank you!

    #6265
    AvatarAnonymous
    Inactive

    Thank you for the answer!
    I’m following all the informations about “loading software” and ALMOST everythings look good.
    When I write : G00 Y10;, only one of my two motors is moving, and not moving the bobine but it’s
    more like “shaking” ๐Ÿ˜• That’s weird.

    I guess the motors aren’t well connect to the adafruit hardware?
    My motors came with 4 cables: 1 black, 1 red, 1 blue and 1 green. So there is no Yellow…
    I replaced your yellow by my black in the command, maybe I shouldn’t?

    Any suggestions? Thank you very much!!!

    J.

    #6266
    AvatarAnonymous
    Inactive

    Hi, Jerom.

    I have a number of things I would try.

    – disconnect the motor that doesn’t work to simplify testing.
    – make sure motor shield is getting 12v power.
    – make sure the connections are good.
    – try swapping red and black, or black and blue. You steppers should have a data sheet somewhere, and what you want is to make sure coil 1 is on the first two connections and coil 2 is on the second. You also want to make sure current is flowing the correct way through each coil.
    – you can use the jog commands, D00 [L/R][number of steps]; to turn each individual motor. number of steps can be negative. This might be easier for testing because D00 doesn’t care about your machine configuration.

    Does that help?

    #6267
    AvatarAnonymous
    Inactive

    I know from where comes the mistake.
    the two motors aren’t “powerfull” enough (3V only) and I read in the adafruit manual that
    it has to be between 4,5V and 25V.
    So I’m now trying to find a place where i could buy new motors here close to Brussels (belgium)!

    I’ll let you know when I’ll have solved this problem ๐Ÿ˜‰
    Thank’s again

    #6268
    AvatarAnonymous
    Inactive

    by default the kit comes with 12v0.3a steppers. the shield can support up to 24v1a steppers.
    When you get your custom design working, please share pictures or video!

    #6269
    AvatarAnonymous
    Inactive

    I’m back!

    Glad to say I found two motors that works great!
    but right now my problem is that I can’t open the start.bat software! I’ve been looking on the internet
    to find a reason and it seems that it’s impossible on mac?! I’m just able to open it in textedit but that’s it.
    I also tried on Linux and no more success.

    Do you know how I could launch this software without using Windows?

    Thank you

    #6270
    AvatarAnonymous
    Inactive

    Go to http://www.makelangelo.com/
    Click “Download control app for OSX ยป” to grab the latest copy.
    Open the DMG.
    Click DrawbotGUI.jar.
    If that doesn’t work, try clicking start.command.

    When you get it working, post a video here, please!

    #6271
    AvatarAnonymous
    Inactive

    I have tried many different folder configurations for the rumba firmware to use with my new Makelangelo 3 controller, but all end with compile errors. I know that I need a firmware_rumba folder in the arduino/libraries folder that contains the firmware_rumba.ino file and that h files normally get their own folder. Beyond that I’m in need of help in getting this setup functional.

    #6272
    AvatarAnonymous
    Inactive

    http://learn.marginallyclever.com/index.php/Stewart_Platform_2_Steppers_Motors

    This shows you how to translate the colors and should help get rid of the shaking. What is happening is the stepper motor is supposed to activate alternating pairs of magnets to make the machine step. If the wires are in the wrong order then the same coil is being activated over and over again (or something similar).

    #6273
    AvatarAnonymous
    Inactive

    The reply post appears to be in the wrong topic.

    #6274
    AvatarAnonymous
    Inactive

    firmware_rumba does not need to be in the arduino libraries folder.

    When running the Arduino software, open firmware_rumba/firmware_rumba.ino. Arduino should open several tabs at once. Set the Arduino > Tools > Board to “mega 2560” and click upload. You may have to play with Arduino > Tools > Port to make it go to the board.

    Yes, that other post is in the wrong thread. I don’t know how it ended up here.

    #6275
    AvatarAnonymous
    Inactive

    Thanks. It loaded with no trouble. I have LCD working and motors under control. I just posted another topic on the servo connection.

Viewing 19 posts - 1 through 19 (of 19 total)
  • You must be logged in to reply to this topic.