Software help

Home Forum Makelangelo Polargraph Art Robot Software help

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #5924
    AvatarAnonymous
    Inactive

    Hi,

    I’ve been playing with the Polargraph drawbot for the last year with great results and thought I would try out the Makelangelo software over the weekend on my drawbot hardware. I have two of them, one large system for big shows and a smaller tabletop one (which I’m using at the moment)

    I’ve downloaded the latest software from Github and uploaded to Arduino Uno (0.9.2b) and also loaded the latest java GUI for MacOSX (0.9.4)

    Arduino connects to the GUI and I can see the commands going back and forth and I can jog and move the steppers etc.

    However, the GUI does not appear to send the information on the spool diameter to the Arduino and hence the drawing dimensions are totally screwed up (I’m using 3.5cm dia spools) also, setting the speed doesn’t appear to do anything either.

    it appears that the Arduino is using the default values of the spool diameter (0.95??) and hence the scaling is completely out of wack.

    Any help or suggestions much appreciated!

    TIA

    Bob

    #6392
    AvatarAnonymous
    Inactive

    Hi, Bob.

    I’ll be working on the makelangelo later today. I’ll try changing my bobbin sizes and feed rates to see if they have broken somehow.

    #6393
    AvatarAnonymous
    Inactive

    Thanks Dan πŸ™‚

    #6394
    AvatarAnonymous
    Inactive

    Looks like you were right! The arduino knows what to do with D01 commands but the GUI wasn’t sending them.
    I’ve modified the code and it will go out in the next update.

    Thank you!

    #6395
    AvatarAnonymous
    Inactive

    Hi Dan

    Do you have a timeline for releasing the updated OSX software?

    Bob

    #6397
    AvatarAnonymous
    Inactive

    Hi Bob,

    Sorry for not seeing this message earlier. I just pushed an update through. Please get it here:

    https://www.marginallyclever.com/other/Makelangelo.zip
    or
    https://www.marginallyclever.com/other/Makelangelo.dmg

    If those don’t work you can try direct access:

    https://www.marginallyclever.com/other/Makelangelo-0.9.6.zip
    https://www.marginallyclever.com/other/Makelangelo-0.9.6.dmg

    Please let me know if that fixes the issue.

    #6398
    AvatarAnonymous
    Inactive

    Hi Dan

    I’ve tried with this version but it still doesn’t seem to accept the bobbin sizes. There is also an issue with the speed not taking, seems to be fixed at 2000 and this causes the steppers to miss.

    Sorry about this but I’m going back to my Polargraph code πŸ™‚

    #6396
    AvatarAnonymous
    Inactive

    Hi, I’d also like to chime in to report that the speed setting seems to have no effect. I’ve been testing using the provided gcode files. Thanks for a great project!

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.