Servo Jitter issue and rotary knob not responding well

Home Forum Makelangelo Polargraph Art Robot Servo Jitter issue and rotary knob not responding well

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #27928
    AvatarMarinus de Beer
    Participant

    Hi all,

    So I’ve been making a lot of progress with the Makelangelo DIY ‘clone’ working with Ramps 1.4 and an Arduino Mega. Now am working on a linear-rail supported pen lifting system. All good. Will share soon once I get some issues out of the way so that I can actually test the system.

    There are two issues I’m having and I haven’t been able to solve it. I’m trying to fix it for about ten hours spread over several days now.

    ——————————-
    Issue #1 – Servo:
    – Servo lifts and lowers fine
    – On drawing moves the servo is jittering back and forth causing the pen to lift up and down a bit causing the carriage to wobble causing curvy straight lines

    Here is a video illustrating the servo moving about randomly:

    What I’ve tried:
    – Four different servo motors, metal gears plastic ones, etc.
    – Separate power supply to power the servo from external 5v instead of the on-board 5v supply
    – Added toroid ferrite cores to all leads to make sure it wasn’t a noise issue
    – Removed the stepper drivers and the motor leads to make sure it isn’t any form of noise
    – Checked out if maybe the gcode files are corrupted
    – Set different speeds in Makelangelo firmware
    – Tried 3 different Ramps boards and tried three different Arduino Mega’s
    – Tried using a buck converter instead of 5v external power supplies
    – Tried using a short lead to connect the servo (directly onto the board)

    Nothing has helped and I’m suspecting the issue is in the firmware. Does anyone have an idea where to look, or maybe already know a solution to this issue? It is driving me nuts. I have had so many issues with the project that I have overcome, but this is the only one where I 100% do not see a solution that I can fix as I now suspect it is in the firmware but I am still not sure.

    ——————————-
    Issue #2 – Rotary encoder knob:
    The rotary encoder knob is really hard to use, it doesn’t register turns well. Presses are registered though. Sometimes it skips two menu options and sometimes it just doesn’t want to go to the next option in the menu.

    What I’ve tried:
    – Different LCD panels (I have three)

    No solution found as well. It must be in the firmware as these LCD panels are confirmed working correctly under Marlin firmware.

    The machine is on it’s way to be the final model soon, but these issues are holding me back. I so wish to improve it to the level where I can produce work with it, but in this manner it is not possible to work with it.

    As you can see here the machine is capable of producing dimensionally perfect shapes, but the servo is messing up the straight lines:

    The initial pen lift and raise cause a line to form at the beginning of each line, this is easily solved when the servo is working correctly. Please help a brother out! 🙂

    #27930
    DanDan
    Keymaster

    Have you tried the latest dev branch of the firmware? It may have better knob response.

    #27931
    AvatarMarinus de Beer
    Participant

    Hello, I finally managed to fix the servo issue. It turns out the blue plastic geared servo motors do not work with this hardware and firmware combination. But I got a friend to borrow me a couple of metal gear servos to test and I managed to find one that works.

    No clue how fast micro servos wear on a vplotter, but fixing the servo naturally fixed all of the other issues I was having except the rotary encoder of course.

    I just discovered I’m using the latest master and not the latest DEV. I’m terribly sorry. I never understood github that much and I will try out the DEV branch later today!! Pretty ashamed to say I only found out about the DEV branch today after years of using github haha. I never clicked the ‘branches’ tab and always assumed the main page would display the latest branch. This is how it works with Marlin for example.

    #27932
    AvatarMarinus de Beer
    Participant

    Okay rotary encoder in the dev branch seems to work really well, however, the right motor seems to suddenly be working the other way around and the home position is not working anymore. Turning around the cable for the right motor seems to fix it a little bit, but the machine now starts printing up way too high.

    Do I need different settings for the new dev firmware? I cannot print with it the way it is because either the carriage goes to the top or it rams into itself. Homing is disabled and I have made sure all the settings are identical to the latest master firmware that works fine on this machine.

    Oh and some advice for the file menu, SDfat works really well but it would be nice if the list was ordered in such a way that the latest file would be on top since now you can’t scroll to the bottom of the list by moving up with the rotary encoder.

    #27934
    AvatarMarinus de Beer
    Participant

    Changing back to the master version fixes all the issues I’m having with the dev version. I’m not sure what the difference is, but all I can say is that the dev version absolutely does not work. The dev version does however have a correctly working rotary encoder and I really like the SDFAT system. If anyone has some advice on how I can ‘fix’ the dev version so that the motors work again, I can finally start testing the dev branch. Am I in the right place? Should I put my comments in the github? It’s kinda quiet here 🙂

    #27997
    Avatartjhawkey
    Participant

    I have been trying to revive my Makelangelo 5 recently. I had it working great last year, but then got lost in the swamp of hardware and firmware upgrade. There has been a change in stepper motor configuration. Used to be that the firmware default was for 400 step motors, but newer versions of the official hardware use 200 step motors. Another change that’s happened someplace is the home position. Used to be in the middle, about a foot down from the motors. Now it’s set to where the limit switches engage (bottom middle). Mechanically, I can see the point, but something seems disconnected between the dev firmware and the software (for me at least).

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.