Ramps 1.4 and Mega 2560

Shop Forum Makelangelo Polargraph Art Robot Ramps 1.4 and Mega 2560

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #30103

    Firmware 9.2.0
    Makelangelo software 7.31
    Windows 64 bit

    Hardware tests successfully using Ramps arduino test code
    Successfully loaded firmware 9.2.0 with no LCD, No limit switches
    Got the Hello screen from the serial. Entered G1 x100 y 100 into arduino serial and got nothing, but it wasn’t clear that I should.

    Installed Java SDk 17, and open Makelangelo. Load art seems to connect to arduino, but there is no movement from plotter controls. Marlin interface returns code you: M400 . Pen up or pen down also does not work, but I was able to test the servo in a servo sketch using the same pin defined in firmware, so not hardware. Clicking Draw asks for pen color, then no movement. Again motors and board were tested with arduino sketch, so ample power, and hardware works with pin assignments. I disabled firewall in windows to be sure, but saw I would get an error if it was a firewall issue and I do not.

    Should I be able to issue commands from the serial monitor in the arduino ide/firmware set-up?
    What setting could I have missed in firmware, that would have allowed the build to be successful, but would result in the problems I am experiencing?

    Thanks ahead of time.


    Did you home the robot before attempting moves?

    G28 XY

    will home the machine. after long periods of inactivity it may turn off the motors for power saving and force you to re-home the machine.


    I’m in the same boat. Were you able to make any progress?

    I get repeated lines of “You: 400”, then after a time “Error:No answer from the robot, retrying…”


    I´m having the same problem.


    @nadeego please post your entire conversation with the robot. if all you see is “you:400” several times then your robot is not talking to the app. that means you have either a robot problem or a USB problem.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.