Newbee help configuring firmware for RAMPS. Is this correct?

Home Forum Makelangelo Polargraph Art Robot Newbee help configuring firmware for RAMPS. Is this correct?

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27506
    Avatardisneytoy
    Participant

    Greetings!

    I have been away for a long time. I had collected lots of parts a year or 2 ago, but never got it up and running.

    So I now have your latest firmware loaded in the IDE, I’m guessing my Ramps would be easiest to get going, I also have Wmos D1, ESP32, ESP8266 as well.

    I need a little hand holding to get this running:-)

    So what else do I need to do in the IDE?

    1) In configuration.h, #define MOTHERBOARD BOARD_RAMPS

    2) I don’t have the LCD so is this correct”

    //#define HAS_LCD // if you have an LCD panel
    //#define HAS_SD // if you have SD card support on your LCD panel (must be on panel?)

    // only uncomment one of these options
    //#define LCD_IS_128X64 // reprapdiscount Full Graphic Smart LCD Controller
    //#define LCD_IS_SMART // reprapdiscount Smart LCD Controller (including XXL model)

    3) Microsteps is 16, so 3 jumpers per A4988 driver.

    4)I have 22 tooth pulleys so:

    // Marginallyclever.com uses GT2 timing belt, which has 2mm teeth.
    // We also use GT2-20 pulleys which have 20 teeth.
    // 20*2 means the pitch is 40. (so, 22×2-44?)
    #define PULLEY_PITCH (40.0) (should be 44)??

    Anything else I need to configure?

    Thanks Dan!

    Max

    #27507
    Avatardisneytoy
    Participant

    Also.

    What is the default distance between motors?

    Where in the firmware do I set my canvas dimensions, or is that set in the software?

    For the polargraph on the RAMPS Am I correct that the X motor is on the left, and the Y motor is on the right?

    Thanks again!

    I follow you on IG and it always inspires me to get this working. Just have to get over the first hump.

    #27508
    Avatardisneytoy
    Participant

    UPDATE: I uploaded the firmware without issue to the ramps.

    I did find a Full Graphic Smart LCD Controller so the display and SD are uncommented now.

    My display is blank. but that may be a issue with the LCD and not firmware.

    I ran your software, connected. and tried to start a drawing. Even with the display blank , I hit one of the buttons and I can see it running on my PC. Now to get the hardware running:-)

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.