Message "Makelangelo not coneccted"!! please help!!

Home Forum Makelangelo Polargraph Art Robot Message "Makelangelo not coneccted"!! please help!!

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #5986
    AvatarAnonymous
    Inactive

    I´m setting up the makelangelo and I can comunicate with the UNO by the serial port com9 in arduino serial monitor the display message shows that all is correct like in the instructions but I can´t move the stepper with the command G00 Y10 (I´m using the adafruit motor shiel v2 versión of the firmware) it seems that there is comunication because the led tx blinks.
    but for me the biggest problem is that on the top of the program displays “makelangelo not connected” I have done everything change the ports to com3 back again to com 9 and the java program tells “Port could not be opened:Unknown Application”.
    I can´t fix this problem and I think I´m going to get crazy! 😮
    What should I try? everything seem to be in order but don´t work! 🙄

    #6578
    AvatarAnonymous
    Inactive

    The firmware for AMS2 and AMS1 are badly out of date. I’m working this week on bringing them back up to working condition.

    The only firmware I’ve been testing is the RUMBA. I am in the process of setting up a v2 again so I can update everyone.

    Anyone care to give me a hand can join in the github project.

    #6579
    AvatarAnonymous
    Inactive

    oh my GOD!! I was going to jump througt the window!!! 😆

    So you mean that the firmware of the motor shield v2 and v1 can´t connect the java whith the arduino? but this software was working before there is a lot of people who did it. Its extrange for me I´m not a software master , rather I´m a software victim!! 😆

    I´ll try the RUMBA versión and see what happen. I´ll be very happy to can help you but like you see I only can disturb in software questions. 😕 anyway congratulations for your work and thank you very very much for your fast answer you did the good action of the day!! 😀

    #6580
    AvatarAnonymous
    Inactive

    Please follow these steps:

    – pause.
    – breath in.
    – breath out, slowly.
    – repeat until you are calm.

    I changed the way lines are processed. Arduino serial window can send new line (n) characters. So instead of waiting for “;” symbol in serial window I wait for “n” symbol. Older firmware still expects “;”. If you watch the serial messages in Makelangelo software you will see many commands TO the arduino in white but no “>” returning to the PC … because the arduino is still waiting for “;” before it processes the command.

    I have just released an update in github that fixes the issue for AMS1. AMS2 might also work but I haven’t tested it.

    #6581
    AvatarAnonymous
    Inactive

    Out of curiosity, how do you monitor the serial communications in the Makelangelo software? I don’t see a setting to open a window…do you just check out the log file after all’s said and done?

    #6582
    AvatarAnonymous
    Inactive

    I don’t understand the question. As I receive data from the arduino I log it to the log window (bottom left) and to a log.html file in the working folder. I use CSS to color messages so the user can tell which way the message is going. Below the log window is a % complete, (sofar/total number of commands) total:since:start and estimated:time:remaining.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.