Makelangelo Software crashes sometimes

Home Forum Makelangelo Polargraph Art Robot Makelangelo Software crashes sometimes

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #29661
    art-and-piano
    Participant

    Hello,
    my first question is: are there some minimum requirements for the computer (Windows 10) to run the Makelangelo software?
    I built a polargraph with Arduino Mega, Ramps 1.4 Board and Drv8825 drivers. It runs with 7.24.5 as Makelangelo 3.0-3.2 and firmware 9.1.0 (oddly 9.2.0 is not working with my machine).
    Sometimes after a few hours of drawing the machine stops (the intervals are irregular), then I have to restart the computer and software, have to recalibrate the home position, and then I can continue the drawing from last #line. The drivers do not seem to overheat, even after hours I can touch them and they are just warm, but not really hot.
    Thank you
    Thomas

    #29663
    Dan
    Keymaster

    Does the drawing complete if run from the SD card? That way we can eliminate the computer as a suspect.

    #29664
    art-and-piano
    Participant

    Because I built the robot by myself with the components I mentioned, I have not the possibility to run from a SD card. So I thought maybe the computer has to have some specific requirements to run the software flawless.

    #29666
    art-and-piano
    Participant

    I think I found a solution: for Java I increased in the control panel the maximum heap size of memory to the full amount of 4 GB RAM that are installed in my notebook (with “-Xmx4g” in the Java Runtime Parameters). The machine was running now for 4 hours and 20 minutes without interruption to the completion of the drawing 🙂

    #29722
    art-and-piano
    Participant

    Unfortunately all these these efforts had no constant success in the last few days. The machine still stops drawing, sometimes after 15 minutes, sometimes after hours of drawing.
    I tried all these things:
    – Increase maximum RAM heap size for Java
    – Increase swap memory in Windows
    – Disconnecting from the Internet and turning-off Windows firewall and turning-off Windows Defender while drawing.
    Could you please help me with this problem? I’m really desperate.

    #29723
    art-and-piano
    Participant

    I tried also now to run the new software 7.26.0
    But when I try to start it with start windows.bat I get this error message:

    Error: A JNI error has occurred, please check your installation and try again
    Exception in thread “main” java.lang.UnsupportedClassVersionError: com/marginallyclever/makelangelo/Makelangelo has been compiled by a more recent version of the Java Runtime (class file version 59.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.