Makelangelo 5 USB connection problem

Home Forum Makelangelo Polargraph Art Robot Makelangelo 5 USB connection problem

Viewing 25 posts - 1 through 25 (of 68 total)
  • Author
    Posts
  • #21635
    Avatarmanole_83
    Participant

    I read the RepRap Correction from https://reprap.org/wiki/RUMBA#Troubleshooting and I identified the pins indicated in images, but I don’t understand which jumper to which pins I have to connect. So I have attached my Rumba image with jumpers and pins marked with colored indicators. So tell me what jumper to what pins I must connect.

    See that the jumpers are in blue (up and down) and red, while pins are colored in green and violet.

    I know it seems rudimentary for you, but I am an artist not a specialist in IT…
    Thank you very much for your help and understanding!

    Sorry I can’t upload the image…(it requires me url…?) anyway, you have it in the e-mail I have send you as doc.

    #21659
    DanDan
    Keymaster

    rumba pins

    The yellow jumper in the red box should be on the middle pin and the “stand alone” pin. otherwise the machine does not have enough power to run the motors.

    The other jumpers are not important.

    #21667
    Avatarmanole_83
    Participant

    I have send you by e-mail the image of Rumba as how I placed the jumpers. The red one I moved down in so called „USB power position” (see position 1 from this image https://dl.dropboxusercontent.com/s/9l44cu2vmvraepj/Rumba_DFU.JPG?dl=0) and I added a jumper (my own), noted with blue on the 2 position. Is this a correct positioning or I would have to use a jumper from the right (the yellow one) three row for the 2 position, where my added jumper is?

    #21668
    Avatarmanole_83
    Participant
    #21675
    DanDan
    Keymaster

    We do not have any instructions about the #2 jumper. I don’t know why you decided to add it OR what it will do. Please remove it.

    Please install arduino app (http://Arduino.cc)
    open app
    connect power & USB to robot.
    click tools > port > [something] mega 2560.
    click the magnifying glass (far right)
    change baud to 57600.
    change newline to “newline”.
    Hello World message should appear.
    type “G28” and hit enter.
    robot should home automatically.

    Please let me know your results.

    #21679
    Avatarmanole_83
    Participant

    Port is blocked. But I have some good news, when I plugged the USB the Arduino Mega 2560 was installed and I have it added in Device Manager as Universal Serial Bus devices.

    #21680
    Avatarmanole_83
    Participant

    I downloaded and installed Arduino software from here, firs option: Windows Installer, for Windows XP and up.

    #21681
    Avatarmanole_83
    Participant
    #21682
    Avatarmanole_83
    Participant

    I extracted the jumper from the #2 position and the one from the #1 position is still there.

    #21683
    DanDan
    Keymaster

    The only jumper I care about is the “stand alone” jumper.

    Now that your PC recognizes the RUMBA as a mega2560 you should be able to connect.

    #21684
    Avatarmanole_83
    Participant

    The problem is that the Tools-Port is grey. Doesn’t work.

    #21685
    Avatarmanole_83
    Participant

    The Arduino 1.8.8 doesn’t recognize the USB.

    #21686
    DanDan
    Keymaster

    You have jumper set to “stand alone”? see yellow jumper here: https://images-na.ssl-images-amazon.com/images/I/51K6Bo1cxOL._SX385_.jpg

    You have power to robot?

    You have USB connected?

    You have driver installed?

    USB device appears in windows > settings > bluetooth & other devices > other devices?

    Arduino > Tools > Port still grey?

    #21687
    Avatarmanole_83
    Participant

    If I go in File-Preferences-C/Users…Arduino15/preferences.txt (left-bottom of the page) and open with Notepad, doesn’t have serial.port.

    #21688
    DanDan
    Keymaster

    What the hell is File-Preferences-C/Users…Arduino15/preferences.txt? You’re not answering my questions.

    #21689
    Avatarmanole_83
    Participant

    I dont have in Device Manager : bluetooth & other devices > other devices

    #21690
    Avatarmanole_83
    Participant

    The Arduino Mega 2560 appears only as Universal Serial Bus devices.

    #21691
    Avatarmanole_83
    Participant

    Arduino > Tools > Port still grey.

    #21694
    DanDan
    Keymaster

    The only time I’ve heard of the Mega 2560 appearing in the bus devices AND arduino/etc not being allowed to connect was when a student used a school computer and the school security system would not allow remote device connections.

    Because this is so rare I have opened a ticket with arduino: https://forum.arduino.cc/index.php?topic=592734.msg4030341#msg4030341

    #21695
    DanDan
    Keymaster

    > The Arduino Mega 2560 appears only as Universal Serial Bus devices.

    And you installed the RUMBA driver? Some of this conversation is lost because you keep trying to email me half of what is said. Here is the link again for the driver: https://reprap.org/wiki/RUMBA#RUMBA_USB_Driver_for_Windows

    #21696
    Avatarmanole_83
    Participant

    No. I didn’t installed. Is Rumba Taurino, Right?

    #21697
    DanDan
    Keymaster

    Taurino is not Rumba.

    #21698
    Avatarmanole_83
    Participant

    PLEASE FOLLOW THE LINK YOURSELF AND TELL ME WHAT ZIP TO DOWNLOAD. THE NAME OF SETUP ONE IS RUMBA TAURINO. THE OTHER HAS ONLY A ini and inf folders.

    #21699
    DanDan
    Keymaster

    https://reprap.org/wiki/File:RRD_RUMBA_TAURINO_DriverSetup.zip

    I’m sorry. I didn’t see Taurino in the name. Taurino is an off-brand mega 2560 clone. I did not know they use the same driver file.

    #21700
    Avatarmanole_83
    Participant

    Please announce me when you have a trusted link. Thanks for your patience.

Viewing 25 posts - 1 through 25 (of 68 total)
  • You must be logged in to reply to this topic.