Makelangelo-28BYJ-48 motoe moving only one way

Home Forum Makelangelo Polargraph Art Robot Makelangelo-28BYJ-48 motoe moving only one way

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #13666
    AvatarAnonymous
    Inactive

    Hi,
    I’ve downloaded all of the java and arduino files, installed and assembled everything..

    when i click Draw -> start , the stepper moves very slowly (1-2 steps per second), and always and only in one direction.

    when I click start – i get this error message that i need to change something to 0.
    I’ve tried to change the speeds.

    Also – i can’t make the drawing smaller so it will fit my paper (so i’m using only drawings that originally fit, like the ‘Hello World’).

    #13671
    DanDan
    Keymaster

    please:

    – java and arduino files for what?

    – what is the entire error message?

    #13689
    AvatarAnonymous
    Inactive

    the files were these ones that I’ve downloaded from the link in this youtube video.

    the error message is “Please change to 0 and click OK.”

    Thanks for your help,
    Yaniv

    #13693
    DanDan
    Keymaster

    hmm… well, we don’t support those stepper motors (idk of anyone who’s tried them yet) and fishing line was thrown out a long long time ago. the java code is ok but I’v enever heard of “please change to 0 and click ok”, the zero should be a name of a color. You installed the Arduino code on your board, too? For all I know you’re using a funny motor shield. I’m quite tired this evening, I hope I’m not being difficult.

    #13711
    AvatarAnonymous
    Inactive

    Can you please detail your setup?
    I have mine running and making fine drawing using 28BYJ48.
    Will be glad to help you.

    #13719
    DanDan
    Keymaster

    @rsnrsnrsn Today you are my hero.

    #13732
    AvatarAnonymous
    Inactive

    its exactly the same setup as show in the video, while the steppers are connected to pins (2,4,3,5) and the second one to (A0,A2,A1,A3).
    what more details can i give?
    Thanks!

    #13740
    AvatarAnonymous
    Inactive

    That setup didn’t work for me. Different problems while drawing. So I bought a Motor Control shield based on L293D and it worked.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.