JAVA Opening COM Port message ààààààààà

Home Forum Makelangelo Polargraph Art Robot JAVA Opening COM Port message ààààààààà

  • This topic is empty.
Viewing 14 posts - 26 through 39 (of 39 total)
  • Author
    Posts
  • #6201
    AvatarAnonymous
    Inactive

    if you have drawbot software running you cannot open a second serial connection at the same time (arduino window).

    So you:
    – reboot computer
    – start arduino
    – connect to drawbot
    – get hello world message
    – type config and get >
    – type teleport and get >
    – type “G00 X10;” and get…?

    #6188
    AvatarEdmondsLibrarian
    Participant

    Forgot to reboot. SIlly.

    I’m not able complete the step of connecting to the Drawbot in Arduino. (No hello world message or response.)
    Perhaps this is a hint about the problem?

    Other possible details- Board set to Uno; Serial Port is correct; programmer on AVRISP mkII. Serial window set to Autoscoll, No line ending, 4800 baud.

    #6189
    AvatarAnonymous
    Inactive

    Aha! Your baud should be 57600. anything else and you’ll either see nothing or get gibberish.

    #6190
    AvatarEdmondsLibrarian
    Participant

    I changed the baud rate to 57,600. There is still no “ready” or hello world message in Arduino. (And no response to typed commands.)
    I wonder if there is an Arduino Library example I could install and run? Just not sure. Grateful for your suggestions.

    #6187
    AvatarAnonymous
    Inactive

    We may need to live conference or something. if your baud rate is correct and you’ve successfully uploaded the firmware then you should get a hello, world message when you open the serial window and set the baud to 57600. If that’s not happening then something else is not going right and I need more information to figure out what that something is.

    #6191
    AvatarAnonymous
    Inactive

    I’ve got another customer reporting this wierd bug and he lives in town so I’m going to go over there and see what this is about in person. I should have something to report by monday.

    #6212
    AvatarAnonymous
    Inactive

    Ok, I just checked in version 0.8.6. This should fix the issue which appears to be a stack overflow on the Arduino.
    You will need to update the firmware on your Arduino. Please give it a try and let me know if it helps. Thank you!

    #6213
    AvatarAnonymous
    Inactive

    Hi, I’m new to all this and have had success with commands from the Arduino serial monitor, but am having trouble with the GUI. No probs with the configuration as far as I know. Jog motors seems to work, but the L commands my right motor (the one connected to M1 & M2 on the motor shield) and vice versa with R.

    The Drive Manually menu isn’t working for me. I was getting error messages prior to version 0.8.6. Now I don’t get the errors but I don’t get any response from the motors either, with the exception of FIND HOME, which seems to spin them indefinitely. Here’s a sample from the log after pressing Y10:

    G91;
    G00 G21 Y10;
    G90;
    M114;
    >
    f1=2984.51mm/min> > X0.00 Y0.00 Z90.00 Ff1=2984.51mm/min

    On my end, I see two potential problem areas:
    1. I get this warning when I run start.command (I’m running OS 10.6.8):
    WARNING: RXTX Version mismatch
    Jar version = RXTX-2.2pre1
    native lib Version = RXTX-2.2pre2
    2. I’m running a 64-bit processor and am not sure if that jives with the serial output.

    Any thoughts?

    Many thanks.

    #6215
    AvatarAnonymous
    Inactive

    Hi!

    Are you using the recommended hardware? It’s really hard to provide support if you’re using anything else.
    Have you configured your limits?

    The “RXTX Version mismatch” message is well known and not a concern at this time.

    If you can jog motors then the board is correctly receiving and interpreting gcode. it’s also executing it and moving steppers. Try hitting “this is home” before any other moves.

    #6217
    AvatarEdmondsLibrarian
    Participant

    I have tried installing the latest version from GitHub. 0.8.6.
    Unfortunately, I must have removed too many of the old files, as the Java GUI program doesn’t start. (neither the one inside the WIndows folder, or the next level up. The Command prompt opens and closes for the start file.) I also don’t have the “Hello World” message in Arduino Serial window.
    I’m going to try to set aside time later in the week to do a clean install. Got my fingers crossed! We’ve come so far.

    #6214
    AvatarAnonymous
    Inactive

    Please tell me where you are stuck. I don’t have enough info to help.

    #6216
    AvatarEdmondsLibrarian
    Participant

    It’s OVER! I’ve got a VERY NICE working Drawbot. Thank you for the Google Hang Out assistance. It’s run the code for the sample images as well as a new heart picture! SUCCESS!
    The issue I was having seemed to be in the start file, and the way it calls up the GUI. (It’s a windows things for sure.) Our “Robot Overlord Master” has made a great program, and I look forward to using it in my school and personal life! (Next step a little fine tuning…) Thank you, thank you. It was totally worth the time!

    #6218
    AvatarAnonymous
    Inactive

    Hi
    I seem to have the same problem. I never had the “Hello World I am drawbot”
    Prior to receiving the ààààààààà repeatedly, I had the message “original firmata something something something italian sounding”, suggesting that my poor little Aruino doesn’t know that it is supposed to be a drawbot. I think once I get the firmware installed I should be able to follow through the rest of this thread to get things up and working.

    Things I’ve done so far: added AFMotorDrawbot to the Arduino Library.
    Clicked some buttons unsuccessfully.

    Thanks!

    #6219
    AvatarAnonymous
    Inactive

    I think I have a similar problem with the firmware not being installed. When I connect in the Java console I get the message “
    “Opened.
    U oy StandardFirmata_2_2_forUNO_0_3 +”

    I have two units and I received the same message. After trying a few things and clicking some buttons, I also managed to get the “aaaaaaaa” messages. I’m new to Arduino so I could certainly use a hand getting things sorted out.

    Thanks!

Viewing 14 posts - 26 through 39 (of 39 total)
  • You must be logged in to reply to this topic.