Help with new robot

Home Forum Makelangelo Polargraph Art Robot Help with new robot

  • This topic has 1 reply, 2 voices, and was last updated 1 month ago by Dan.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30209
    Chris Snowdon
    Participant

    Hi,
    I’ve put together a polargraph robot for use with my computing students at school (I’m a teacher).
    It is simply a couple of Nema17 steppers with a standard servo, two lenths of GT2 belt and a couple of timing sprockets. It is built on a whiteboard with a drawing area raised to be level with the motor sprokets (can’t see a facility to add a pic, so my description will have to suffice).
    The controller is a RAMPS14 setup with the RAMPS graphics screen.
    I’ve uploaded the firmware – Marlin bugfix 2.x – and got the robot working, sort of.
    The problem is that is draws on the slant. The image is rotated (about 40 degrees) and not quite square – the edges are bowed. I did a bit of reading and the obvious change was the belt length (mine is 90cm rather than the 1m standard). I changed the setting in configuration.h and compiled/reuploaded the firmware to the mega/RAMPS. No obvious difference – the image is still skewed and slightly distorted.

    I’m sure this problem has happened before, so I’m hoping someone here will be able to quickly point me in the right direction.

    Best wishes and thanks (from my pupils as well)
    Chris.

    #30217
    Dan
    Keymaster

    Answer was found to be 16 tooth pulleys instead of expected 20.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.