Firmaware on Arduino Uno

Home Forum Makelangelo Polargraph Art Robot Firmaware on Arduino Uno

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #20648
    AvatarAnonymous
    Inactive

    I am a graphic designer and fascinated with polygraph plotters. So I tried to build one, bought everything and even screwed it together. So far so good – but the software is still a miracle to me. I am not a technician and I have only basic knowledge about the Arduino. I have an Arduino UNO and a motor shield. I tried to wire it the right way. But I never did any Arduino project before, neither do I know the basics. All together I am a MAC user, which doesn’t make it easier.

    So I am calling for help. I think my mechanic will work. So I have a model where the software could get tested. The javascript file from here opens on my MAC computer, and I am able to make all the adjustments. But the “firmware” which I genuinely don’t understand, doesn’t upload on my Arduino UNO. Maybe it only needs some slight modifications?
    I Used the: Makelangelo – firmware for various robot kinematic models.
    I get the errors: “collect2: error: ld returned 1 exit status exit status 1”

    So here is what I did: I downloaded the firmware, I unzipped the file and I opened the folder: Makelangelo-firmware, clicked the file: Makelangelo-firmware.ino and tried to upload. Errors
    Thank you for the help!

    #20661
    DanDan
    Keymaster

    > doesn’t upload on my Arduino UNO

    Arduino UNO is not supported. At a minimum you’ll need a Mega 2560 with a RAMPS shield OR a RUMBA board.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.