DIY Makelangelo hanging after start.

Home Forum Makelangelo Polargraph Art Robot DIY Makelangelo hanging after start.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #15667
    AvatarAnonymous
    Inactive

    Hey!

    So I’ve been wanted to build a drawing robot for a while and finally got around to it this past month!
    I’m running on and Arduino Mega with Ramps 1.4, and thought everything was going well until I tried to actually start a drawing. To be clear, the manual motor commands from the Makelangelo software work great, and everything seems to be ok until I click the start button for a drawing.

    My output is below. Any help would be appreciated!

    —-Output—

    Generator=Dragon Fractal
    4103 line segments. 969.02246cm Estimated draw time: 11m30s .
    Completed
    �$ E+��n��.#N�N�c*kx�j�j�mX�zQ����1�䡄O���

    HELLO WORLD! I AM POLARGRAPH #-1
    Firmware v8
    D10
    == https://www.marginallyclever.com/ ==
    M100 – display this message
    M101 [Tx.xx] [Bx.xx] [Rx.xx] [Lx.xx]
    – display/update board dimensions.
    As well as the following G-codes (http://en.wikipedia.org/wiki/G-code):
    G00,G01,G02,G03,G04,G28,G90,G91,G92,M18,M114

    HELLO WORLD! I AM POLARGRAPH #-1
    Firmware v8
    == https://www.marginallyclever.com/ ==
    M100 – display this message
    M101 [Tx.xx] [Bx.xx] [Rx.xx] [Lx.xx]
    – display/update board dimensions.
    As well as the following G-codes (http://en.wikipedia.org/wiki/G-code):
    G00,G01,G02,G03,G04,G28,G90,G91,G92,M18,M114

    > D10 V5
    M101 A0 T325 B-325
    M101 A1 T500 B-500
    M101 A2 T170 B10
    G92 X0.0 Y283.0
    D6 X0 Y283
    G0 F6500 A2500
    M17

    > (-325.00,0.00,10.00) – (325.00,500.00,283.00)

    > Saving dimensions.
    (-325.00,-500.00,10.00) – (325.00,500.00,283.00)

    > Saving dimensions.
    (-325.00,-500.00,10.00) – (325.00,500.00,170.00)

    G91
    G00 X0 Y1
    G90
    G91
    G00 X0 Y1
    G90
    G91
    G00 X0 Y1
    G90
    G91
    G00 X0 Y1
    G90
    G91
    G00 X0 Y1
    G90
    M110 N0
    N0 G90*16
    N1 G00 F50 Z90*8
    N2 G00 F6500*126
    N3 M06 T0*82
    N4 G00 F6500 A2500*30
    N5 M117 Change to black Click to continue*47
    N6 M300 S60 P250*20
    N7 M226*34

    #15669
    DanDan
    Keymaster

    M226 is “wait for user input”. it’s waiting for you to click the button on the LCD panel. If you do not have an LCD panel you should rebuild the firmware with HAS_LCD undefined.

    #15678
    AvatarAnonymous
    Inactive

    WOOHOO! Thanks! That fixed it!

    #21601
    Avatartomasbarthalot
    Participant

    Hi Dan! How can I undefine the LCD pannel? I just commented some lines where HAS_LCD appear in the lcd.h file but have no result. In the config.h I can´t find the LCD part, at least the “HAS_LCD” part.
    I would appreciate your help!
    Tomas

    #21614
    Avatartomasbarthalot
    Participant

    Solved it!

    In robot_polargraph.h I was able to change it.

    Cheers!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.