Custom built MEGA+RAMPS+LCD movement problem

Home Forum Makelangelo Polargraph Art Robot Custom built MEGA+RAMPS+LCD movement problem

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #28858
    Avatarakhilesh
    Participant

    Hi I am trying to build a custom machine with Mega 2560+RAMPS+Reprap Full Control LCD (NEMA 17 motors)
    The system turns on . LCD Works but when i try to draw a basic square the gondola moves only left & right (in single line) no vertical movement at all… when i interchange wires the movement changes to up & down with no side movement at all…

    Not sure on what is wrong. tried few permutations of wires but with no luck…

    Any pointers to configure / setup the motors is highly appreciated.

    #28859
    DanDan
    Keymaster

    sounds like both motors are running on the same driver. when one turns left the other turns right, exactly 1:1.

    Also have you set the machine size in the eeprom? Look at D7, M101, and M500-503. if the machine does not know the belt length and square dimensions then the math does not work.

    https://github.com/MarginallyClever/Makelangelo-firmware/wiki/gcode-description

    #28868
    Avatarakhilesh
    Participant

    Thanks Dan for the revert,

    For me also it looked as though both motors were running from same driver but believe me i have two separate drivers (two A4988 on the board of X & Y Axis) and motors are connected to these seperate drivers.

    One more thing i forgot to mention was that i do not have limit switches if that has something to do with this issue.

    Coming to machine size… actually how do you set machine size i could not find out… my machine width is 800mm & height of 800 mm. if there is any guide to set the size in EEPROM please let me know… Thanks again for the revert

    #28871
    Avatarakhilesh
    Participant

    Also one more observation … when i try to move the X axis stepper in “Drive” Menu both steppers connected to X & Y axis move together (Same speed & Direction). Same happens when i try moving only Y axis stepper (Both motors move). So i though some problem with driver or Mega itself.

    I tried flashing Marlin firmware for 3D Printer and in that when i try to move only X axis the motor is moving correctly & independently. So no problem with driver or Mega…

    So what is that i am doing wrong in Makelangelo firmware ?? scratching my head all through the day without any solution… Please help

    #28887
    Avatarakhilesh
    Participant

    Got it to work after complete re wiring…
    Now i have another small problem related to finding home.
    Have installed limit switch and when i press find home the motors turn till limit switches are activated and after that motor stops there only… No further movements.. Pen is in extreme down of machine…

    As per my understanding the pen should go all the way down and post limit switches engagement it should go back to some position around width/2, 200mm from top.

    And also in GUI (Markelangelo software) the home position is always shown in bottom of the machine. it is not showing 20cm from top (may be some configuration issues from my side)

    My machine dimensions
    Width : around 780mm
    Height : around 650mm
    Timing belt : 800mm
    Pully : 40mm with 20 teeth
    Stepper rotation : 200/360 degree

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.