Configuring Makelangelo

Home Forum Makelangelo Polargraph Art Robot Configuring Makelangelo

  • This topic is empty.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #5872
    AvatarAnonymous
    Inactive

    I’m probably doing something silly but my motors are going in the same direction for X5 and Y5. For example I can get X5 and Y5 to both move the plotter up or both move the plotter left or any direction as long as it is the same one, but I can’t get X5 to move right and Y5 to move up.

    Everything works fine when I manually jog the motors but no matter what setting or spool direction I use, X5 and Y5 go the same direction. What am I doing wrong?

    #6220
    AvatarAnonymous
    Inactive

    What does it say when you go to “configure limits”?

    #6229
    AvatarAnonymous
    Inactive

    I played around with that setting. I reset it to what I think is right. I’m assuming that “machine” means the board size so I have it set to 560×760 and drawing 500×700. It is on a white board so the paper size is flexible. It is moving a little better now that I reset those settings but it is moving on diagonals.

    I also played around with limit_top and such but reset it to 0 now.
    static float limit_top = 0; // distance to top of drawing area.
    static float limit_bottom = 0; // Distance to bottom of drawing area.
    static float limit_right = 0; // Distance to right of drawing area.
    static float limit_left = 0; // Distance to left of drawing area.

    #6230
    AvatarAnonymous
    Inactive

    I think I may have finally figured something out.

    The GUI still has me moving on diagonals but sending to the serial monitor is giving me valid X and Y movements…not sure why they are different and if I should be entering the limits in only one place…

    I set

    static float limit_top = 380; // distance to top of drawing area.
    static float limit_bottom = -380; // Distance to bottom of drawing area.
    static float limit_right = 280; // Distance to right of drawing area.
    static float limit_left = -280; // Distance to left of drawing area.

    I had been avoiding negatives because, to me, the word distance implies absolute values, but they seem to help here.

    #6221
    AvatarAnonymous
    Inactive

    You’ve got the right approach. I just updated the wiki instructions, please let me know if they make more sense.
    I also updated the downloads to be 100% certain the firmware is the latest version.

    You may find that Settings > Jog Motors is your culprit.

    When you say diagonal, do you mean that one motor isn’t moving at all?

    #6222
    AvatarAnonymous
    Inactive

    One moves and they other makes a small twitch. The one that moves and reverse changes based on if I click the X10 or Y10 button.

    I’ll go back to the instructions and re-download.

    Since X10 and Y10 work, I was curious what the rest was doing:

    This is what I figured out, let me know if I’m right (although it didn’t tell me why it wasn’t working):

    G91 makes the move relative to the current position
    G00 is fast move
    G21 sets mm
    F2000 sets the feedrate
    G90 switches back to absolute positioning

    G91;
    G00 G21 F2000.0 X-10;
    G90;

    #6223
    AvatarAnonymous
    Inactive

    I’m also getting a message RXTX Version mismatch Jar version = RXTX-2.2pre1 native lib version = RXTX-2.2-20081207 Cloudhopper build

    Not sure if that has anything to do with it

    #6224
    AvatarAnonymous
    Inactive

    Everyone gets that message. I’ll make a note of it on the wiki.

    #6225
    AvatarAnonymous
    Inactive

    If one motor is barely twitching I’d recheck the electrical connections.

    #6226
    AvatarAnonymous
    Inactive

    That would make sense to me if it didn’t move fine when I was using the serial monitor but both motors work smoothly there (sending G00 X5 results in nice movement, sending G00 G21 X5 does not so maybe my scale is off somewhere?)

    #6227
    AvatarAnonymous
    Inactive

    It is working now!

    I have only a bit of a clue why it is working now and wasn’t before. I think the main fix was putting in the negative values for the drawing limit. After that, I think the rest was just removing changes I made trying to get it to work and perhaps I neglected to reset home in the GUI because I assumed it and the serial input would assume the same value for home.

    Anyway, I’m happy. I got to know gcode /the program a good bit better. I just hope the problem I had before never resurfaces.

    #6228
    AvatarAnonymous
    Inactive

    I do everything in mm, by default. It could be that I’ve messed up the unit conversion somewhere and it’s giving one motor the wrong scale? Hrm.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.