Cheap Ramps board doesn't seem to communicate

Home Forum Makelangelo Polargraph Art Robot Cheap Ramps board doesn't seem to communicate

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #21429

    Okay, so I cheaped out and bought on of these, seemed like a good deal:

    And I can upload the firmware and see the Hello World screen in the Arduino IDE
    but, it never wants to connect in Makelangelo.
    D Commands seem to work in Arduino IDE as well (to move the motors)

    The monitor in Makelangelo never shows anything, shouldn’t it say hello there when it connects and the manual driving buttons become active?

    Bad wiring – Would this cause the board to connect via Arduino but not Makelangelo?
    Bad Java install? – I tried two different computers, both had fresh Java installs – JavaSetup8u191
    Bad board? – Yeah I went cheap and expected some issues but it seems odd it works in Arduino and not Makelangelo
    Bad USB cable? – I tried several, but maybe I need to try to dig up another?

    Anyone have any ideas? Thanks!


    An image of wiring in case it’s of any help:
    Ramps wiring


    Just wanted to leave an update, in case anyone else had similar issues.
    I determined the problem was an incompatible combo of firmware and software, (or some form of user error installing one or the other). I had acquired both through Dan’s website by purchasing them.
    After I downloaded the latest of each straight from github I was able to get everything working, for the most part.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.