change languages pig latin to english

Home Forum Makelangelo Polargraph Art Robot change languages pig latin to english

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #20041
    Avataryanax
    Participant

    Hello, I have a problem the default language on Makelangelo 7.15 is the pig latin and I can not put it in English. It does not work through the program menu. Do you have another solution?
    I uninstal the program and instaler again, but it does not work, it’s still in Pig latin.

    Thanks for your help.
    yanax

    #20059
    DanDan
    Keymaster

    On windows machines the setting is stored in the registry keys. Reinstalling the app would load the old keys, changing nothing.

    You could force a reset of all settings for the app. Makelangelo > Preferences > Reset (top menu of app, first drop down option, then third button)

    #20062
    Avataryanax
    Participant

    Thank you for your reply.
    Unfortunately it does not change anything.
    There is the bat file that says that:

    64 bit Windows
    64 bit Java installed.
    The current Java runtime is 1.8
    finding the latest Makelangelo JAR…
    Found Makelangelo-7.15.5-with-dependencies.jar
    java.io.tmpdir=C:\Users\Yanax\AppData\Local\Temp\
    juin 06, 2018 9:32:24 AM java.util.prefs.WindowsPreferences <init>
    WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(…) returned error code 5.

    Thank you for your help,
    Yanax

    #20064
    DanDan
    Keymaster

    First, please try latest version (7.16.1).

    Second, try running it as administrator. right click on the bat file and select “run as administrator”. it might be that your non-admin status prevents the settings from being written.

    If both of these fail then the problem is something deeper.

    #20076
    Avataryanax
    Participant

    Thank you Dan,
    The latest version does not change anything.
    Can not run the .bat mod administarteur.
    It’s strange because I have all rights admin on this pc.
    when i try the bat say’s:

    64 bit Windows
    64 bit Java installed.
    The current Java runtime is 1.8
    finding the latest Makelangelo JAR…
    File not found.
    Appuyez sur une touche pour continuer…

    #20077
    DanDan
    Keymaster

    open windows command prompt.
    go to the folder with the bat file and the Makelangelo-7.16.1-with-dependencies.jar file.
    type

    FOR %A IN (Makelangelo*.jar) DO ECHO %A

    and hit enter. What result do you get?

    #20157
    Avataryanax
    Participant

    Hello, sorry but I can not do anything. I install the software on another pc and there is no problem. I made a pasted copy of the file to replace it on the pc that has problems …. but nothing changes.
    for the CMD, I tried to follow your request, but I did not succeed.

    #20158
    Avataryanax
    Participant

    it’s easy to open the jar file and explore it, but I can not find the language file to change. I delete the pig-latin language file, but it does not change anything.

    #20160
    DanDan
    Keymaster

    close makelangelo-software

    run regedit.

    find Computer\HKEY_CURRENT_USER\Software\JavaSoft\Prefs\/Draw/Bot\/Language\language

    change value data to “/English”

    run makelangelo-software again.

    #20176
    Avataryanax
    Participant

    Thank you Dan.
    This time it’s ok. it’s in English.
    Thank you

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.