• manole_83
    February 17, 2019 at 05:23 #21902

    Hi Daniel, I think I did a big mistake. The board-display is empty now because I made this in Arduino: Tools: WiFi101/WiFiNINA Firmware Adapter: Refresh list or Update Firmware… I wished to connect Makelangelo to Polargraph controller following some indications, but things get out of control… How I can set the display as it was before, with his initial coordinates?

    Dan
    February 18, 2019 at 15:32 #21914

    We are building new documentation now (with pictures) that will explain how to upload new code to the Makelangelo robot. It will explain how to reflash your robot with the correct firmware. We hope to get it done this week.

    manole_83
    February 18, 2019 at 22:36 #21916

    Thanks Dan.I can’t wait to see it! I bet you’re doing a great job, especially for us,the inexperienced ones in dogmas of programming and electronics. Have good time and please SEND ME A LINK when is done!

    manole_83
    February 20, 2019 at 11:23 #21952

    Thanks I’m following right now.

    manole_83
    February 20, 2019 at 12:37 #21955

    Dan, the installation of firmware worked very well but when I opened soft version Makelangelo-7.17.0 I received this when connected:

    „The firmware (code in the brain of your robot) is not the version I expected. I found v.9. Please visit:… for the latest version (gives link for v.8). Please visit:… for the latest software” (link for Makelangelo 7.20.0.

    The link indicated by you (and installed by me) is v.8 of firmware. Also I downloaded and opened the latest version of software: Makelangelo 7.20.0. But the robot doesn’t follow any command, not even Find home.
    What can I do?

    manole_83
    February 20, 2019 at 12:41 #21956

    The steppers are cold and the LCD shows: x 0.0, y 283, z90.0, f 100%.

    Dan
    February 20, 2019 at 15:08 #21957

    I released updated versions of the firmware and the software yesterday evening. You should be on v9 firmware and 7.20 software.

    Can you connect with the 7.20 software to the robot with the v9 firmware? In the message window at the bottom you should see a “hello world” message from the robot and you should NOT get an “The firmware (code in the brain of your robot) is not the version I expected” message.

    manole_83
    February 21, 2019 at 04:58 #21963

    Sorry for insisting but the most advanced version I can find is 8. I searched for version 9 and I didn’t found it. Is there a link for it or I have to update from v 8 installation?

    manole_83
    February 21, 2019 at 08:01 #21965

    Actually the problem is the driver installation and the port, again…

    manole_83
    February 21, 2019 at 08:23 #21966

    I believe there is a problem with the motors.

    I changed the USB port input and now is recognized by Arduino and there is activity in serial monitor. In software 7.20.0 I don’t have any advertisement and when connected the popular driving commands activate but when I give „border” the steppers are cold (always) and seems like only the up-down motor of pen holder activates a wile like a static trembling. So steppers are not moving at command.

    If it helps, the coordinates on LCD are X: 0.0/ Y: 283.00/ Z 90.0/ F 100%.

    I REALLY DON’T UNDERSTAND WHY STEPPERS ARE NOT MOVING.

    manole_83
    February 21, 2019 at 08:25 #21967

    Find home gives no reaction.

    manole_83
    February 22, 2019 at 05:16 #21978

    Do I have to detach and reconnect steppers ports?

    manole_83
    February 22, 2019 at 06:15 #21979

    Or do I have to modify some script in arduino?

    Dan
    February 22, 2019 at 14:29 #21990

    Manole,

    Thank you! You were the first person to install the code and (unfortunately) the first to find a mistake I made. I have attempted a hotfix update.
    Here is the new firmware which should repair the problem: https://github.com/MarginallyClever/Makelangelo-firmware/archive/9.0.1.zip

    manole_83
    February 22, 2019 at 22:28 #21993

    IT WORKS LIKE HOT BUTTER ON FRESH BREAD!! THANKS, GREAT JOB!!!

    manole_83
    February 22, 2019 at 22:52 #21994

    Danel, now that I’m on road again I want to tell you about my concerns before updating the firmware.

    My project involves reproducing images of works of art of great masters. This involves using pixel styles or vector rasterizing which I saw polargraphs are made for. I saw you introduced styles in Makelangelo soft also, but I believe that Polargraph Controller could have more options of modeling them. So my question is:

    HAVE YOU EVER CONNECTED TO MAKELANGELO ROBOT BY POLARGRAPH CONTROLLER, DOES IT WORKS, OR I WILL ENCOUNTER PROBLEMS MAKING IT…?

    manole_83
    February 22, 2019 at 23:08 #21995

    When I try to connect with it has no effect on the soft (tells is not connected) even if an initial shake is transmitted to gondola.

Viewing 18 posts - 51 through 68 (of 68 total)

You must be logged in to reply to this topic.

0
Save & Share Cart
Your Shopping Cart will be saved and you'll be given a link. You, or anyone with the link, can use it to retrieve your Cart at any time.
Back Save & Share Cart
Your Shopping Cart will be saved with Product pictures and information, and Cart Totals. Then send it to yourself, or a friend, with a link to retrieve it at any time.
Your cart email sent successfully :)